Recipients of emails sent by the Sitecore E-mail Campaign Manager module may sometimes see the Page Not Found error pages when clicking the links in the delivered email messages.
As there may be multiple causes of such issues, please review the sections below for the possible solutions and scenarios.
Symptoms:
The links in the email message look like this:
http://<hostname>/sitecore/RedirectUrlPage.aspx?link=<external url>&sc_camp=<campaign ID>&ec_as=<automation state ID>
Cause:
The link was generated by E-mail Campaign Manager 1.3.2 rev. 120424 or earlier version.
Such links would lead to the Page Not Found error if the E-mail Campaign Manager module was later updated to 1.3.3 rev. 121017.
For details, refer to the "Important Changes" section of E-mail Campaign Manager 1.3.3 rev. 121017 release notes:
https://sdn.sitecore.net/Products/ECM/ECM%201,-d-,3/Release%20Notes.aspx
Symptoms:
The URL of the resulting Page Not Found error page looks like this:
http://<hostname>/sitecore/service/notfound.aspx?item=<database name>:<itemID>@<language>
Cause:
The content item with ID <itemID> linked from the email message was not published before dispatching the email.
Solution:
Publish all content items referenced on the email message before dispatching.
In a multi-instance Sitecore environment, the current Message item should also be published before dispatching.
For more details, please see this article: KB0173546
Symptoms:
The URL of the resulting Page Not Found error page looks like this:
http://<hostname>/sitecore/RedirectUrlPage.aspx?ec_url=<url>&ec_camp=<campaign ID>&ec_as=<automation state ID>
Causes:
a) The /sitecore/RedirectUrlPage.aspx page is missing (it was deleted or moved).
b) The value of the "physicalFolder" attribute of the appropriate Sitecore site definition does not correspond to the default one:
<site name="website" hostName=<hostname> physicalFolder="/CustomValue" …. />
Solution:
a) Make sure that the RedirectUrlPage.aspx page is present in the /sitecore folder of your environment.
b) Make sure that the value of the "physicalFolder" attribute of the corresponding Sitecore site definition has the "/" value.
Symptoms:
The problem occurs in a multi-instance Sitecore environment where instances that dispatch emails and process them have different host names.
Cause:
LinkManager configuration has "alwaysIncludeServerUrl" property set to "true" on the content management server:
<linkManager defaultProvider="sitecore">
<providers>
<clear />
<add name="sitecore" type="Sitecore.Links.LinkProvider, Sitecore.Kernel"
addAspxExtension="true" alwaysIncludeServerUrl="true" encodeNames="true" ... />
</providers>
</linkManager>
Solution:
Set the "alwaysIncludeServerUrl" property to "false" on the content management server.
Cause:
IIS is restarted after opening the email but before clicking the link.
Solution:
The issue has been fixed in ECM 1.3.3 rev. 130212. For more details, search for the reference number 377454 in the release notes:
https://sdn.sitecore.net/Products/ECM/ECM%201,-d-,3/Release%20Notes/Release%20History.aspx
To solve the issue, upgrade to ECM 1.3.3 rev. 130212 or later:
https://sdn.sitecore.net/Products/ECM/ECM%201,-d-,3/Module_Upgrades/133_121017_to_133_130212.aspx
Symptoms:
Links from test messages cannot be opened.
Cause:
Links are opened using a browser that does not have an active Sitecore session.
Solution:
In the same browser session where the links are opened, log in to Sitecore Client as an Administrator or a member of the ECM Users or ECM Advanced Users role. This behavior is designed for security purposes.
Symptoms:
Instead of the Not Found error, the link leads to the "403 Forbidden: Access is denied" error page.
Cause:
Anonymous users are not allowed to access the /sitecore/RedirectUrlPage.aspx page.
Solution:
Allow "Anonymous" access to the /sitecore folder of the appropriate IIS site (IIS Authentication configuration):